Page 1 of 1

Panasonic FZ-1 Technical Problems

Posted: Wed Apr 23, 2008 10:37 pm
by rcosner
I just picked up a 3DO on ebay, and it just came in the mail today. I immediately hooked it up, went around to the front of the tv and selected the proper video. I was greeted with the asteroids flying through space, which was good. I then opened the tray and inserted an original copy of Star Control 2 and closed the tray. The 3DO logo popped up for a second, the access light went on for about 5 seconds, then turned off and I only got a black screen from then on. I then tried taking that disk out and just starting it up with the tray closed and nothing in it and it does the same thing, 3DO logo for a second then black screen that never changes. If I open the tray the animated 3DO logo comes on, then the "insert disk" picture is displayed. Needless to say, if I insert a disk at this point and close the tray, the static 3DO image pops up again for a second and it goes to the black screen forever.

I do not hear any disk activity, but (assuming there is a problem with the motor or something) shouldn't I at least be able to get into the menu for the memory and whatnot. Have been unsuccessful in even getting to the little meteor like screensaver thing again. Could it just be a loose wire somewhere inside?

Any help would be greatly appreciated. Here is a link to the one I won, just to provide as much information as possible. ... :IT&ih=019


Posted: Wed Apr 23, 2008 11:11 pm
by 3DOKid
Did you get a purple panasonic disk? That's the bit with memory manager on, you need that disk to get at it. I think only the later FZ-10 models had the inbuilt memory manager.

You might want to clean the lens in some way. It sounds like a disk read error you have there.

Good luck.

3DO Kid.

Posted: Wed Apr 23, 2008 11:24 pm
by rcosner
Ok, so I cracked it open. Apparently my suspicions were a little bit off. The drive does not even spin the disk. I tried using a lense cleaning disk and it wont even spin the cd with the little bristles on it to do any cleaning.

To answer your other question, no I did not receive the purple manager disk, however I don't think that would help as its not spinning any disks at all to be able to read them. I had it apart and it doesn't look very easy to repair that motor, unless its some other easy reason that the motor isn't spinning. Basically I get the feeling I was screwed and I'll end up trashing this one and having to dish out another 70-100 to try again... which is really depressing. Let me know if there is anything else anyone can think of or if there are any websites or links out there to some troubleshooting for a 3DO.

Posted: Thu Apr 24, 2008 2:12 am
by bonefish
I'd return the thing... the auction says that its fully operational, which it obviously is not. They say 7 days to return for refund. Try not to take the hit for and stick it to the dick who sold you a brick.

Posted: Thu Apr 24, 2008 4:05 am
by UnholyTancred
Unfortunately, you got jipped. Return it.

Posted: Sat Apr 26, 2008 2:05 am
by solidus8
if worst comes to worst and you cant return it, you could always try and change the CD laser pickup---If memory serves me right the 3do uses a Sanyo SF-C93 unit. Cheap 15 dollar fix...There are a great many 3do consoles with dead CD drives being sold on ebay as working. Sad to hear you were cheated! Maybe we can we can find a way to fix your unit and others like it. :D

Posted: Sun May 18, 2008 8:00 pm
When I first bought my FZ-1 last year it wouldn't play any games and I thought I got ripped off. I opened it up to look inside and see if anything was dirty or loose but it looked perfect inside so I put it back together and PRESTO it worked after that and has ever since!

I just wish my SegaCD model1 would do that!