Page 1 of 1

Japanese FZ-10 game save troubles

Posted: Wed Mar 12, 2014 1:08 am
by EricK
Hello all. I am new to this forum so will quickly introduce myself. My name is Eric and would not describe myself as a gamer, but I really enjoyed playing the 3DO as a teenager. My oldest brother bought an FZ-10 when they first came out and we loved it. Anyway, he ended up selling it, and we pretty much forgot about it. Also, just a note, I am not the most tech-savvy person, so I will do my best to describe what is happening, but I'll have to keep things in layman's terms for the most part.

Recently, I decided to buy a console because I still have a few games, but no system. I found a Japanese FZ-10 for a pretty good price and in pretty good shape and ended up buying it.

Here is the problem I am having: the console will not allow saved games. That probably sounds strange, but I only own three games, (Road Rash, Killing Time, and Gex) and none of them will allow me to save, even though the console shows that it has the maximum capacity of memory freed up. Every time I access the memory manager it says there is only 152 bytes (I think that's the correct term) used and 32,616 (give or take) free. The screen is in Japanese, but I have been able to access it in English using the Gex game to verify that I'm reading it correctly.

A breakdown of how each game responds: when I put in Gex, before the main menu, a screen pops up saying that there is not enough room to save Gex games. If you press A you can access the memory manager, and pressing C will allow you to play without saving games. Once I access the memory manager (in English), it again shows there is 32k free and shows nothing in the save area to erase. When I put in Road Rash, I can play in "Thrash Mode", but when I go to "Big Game Mode" (which allows saving) and click on Save Game, each spot comes up empty and when I click on "Empty" it does nothing. The Killing Time issue may be something to do with the game, although the CD appears to be in great condition so I have my doubts: Killing Time loads up with the intro video fine and gets me to the main menu screen. When you go to the "Player's Name" screen and enter in a name, after you hit OK, the console sounds like it is loading, and then stops loading. The red "Ready" light stays on and the green "Access" light flashes but it does not make the loud, loading noise that it generally makes. I have attempted to load the game probably 15 times and each time the same thing happens. However, one time it did have a screen pop up saying something to the effect of "Killing Time requires more space to save games, press A to access Memory Manager". When I went into the manager, again it showed max full space and nothing to erase.

I hope that I have made any sense with my rambling and am not sure if anyone has ever seen an issue like this. Again, I am not a savvy game genius, so if anybody has any advice, and can keep it simple, I would appreciate it. I hope that it is something that can be fixed, I would hate to have to go out and buy another console, but at this point, I probably would, because I have really been getting an itch to play some Killing Time!

Re: Japanese FZ-10 game save troubles

Posted: Thu Mar 13, 2014 1:53 am
by BryWI
Have you tried to format the memory? You should be able to with the built in memory manager of the FZ-10 (I thikn it has one... doesn't it?).

Re: Japanese FZ-10 game save troubles

Posted: Thu Mar 13, 2014 5:00 pm
by EricK
It does have a built in memory manager and I can access it by turning on the console and pressing X at the main screen. The only options I have though with the memory manager are to erase files, and again, it shows nothing to erase. Unless I am just missing something...

Re: Japanese FZ-10 game save troubles

Posted: Sun Mar 16, 2014 3:09 pm
by Martin III
I'm not tech-savvy either, but it does sound like the memory has been fried. I can only think of three ways of addressing the problem, and none of them are remotely ideal: (1)Get a 3DO Game Guru and see if it can do anything with the internal memory that the FZ-10's memory manager can't, (2)Get a 3DO memory cartridge and see if you can use that for saving, and (3)Get another 3DO unit. Obviously those all cost money, and if you're only playing three games then a Game Guru and memory cartridge will be of little use to you beyond solving this problem, assuming they even do that. But that's all I can think of. Hopefully someone more versed in the 3DO's inner workings can offer something better.

Re: Japanese FZ-10 game save troubles

Posted: Sun Mar 16, 2014 5:11 pm
by Retrofanatic83
I have a Japanese fz1 and my memory was full. I didn't know this at time as had no way of accessing the memory and it wouldn't save doom so I knew it was full or gone...I got a Japanese copy of gex and on first insertion of the game I was given a message presumably saying the memory was full and allowing me to clear it. This was a relief!
However, all games were saving fine...except for gex! In time I got a memory unit and after transferring the files from the console I managed to get gex working. I would agree with Martin getting the game guru disc or the memory unit and disc would be a possible fix you should be able to clear the consoles memory completely or to the unit and see if maybe something on there is corrupted and get rid of it. Hopefully the memory isn't goosed. I reckon mine has slight issues and by having the memory backed up I feel confident I won't lose my files. Randomly twice in about a year the console has completely lost all my saves so having them backed up is not only handy but essential. The memory manager built in of the fz10 did appeal but I wanted an FZ1 more. Hope you can sort it.

Re: Japanese FZ-10 game save troubles

Posted: Mon Mar 17, 2014 6:08 pm
by Silanda
Dead save battery? Incidentally, Road Rash does not work properly on my Japanese FZ-10 in that it doesn't save and the in race music doesn't play, but everything else I've tried works.