Panasonic 3DO FZ-1 reboots after 5-10 minutes

Got a problem with your 3DO? Ask!
Post Reply
Posts: 1
Joined: Sun Jun 15, 2014 1:46 pm
Location: Netherlands

Panasonic 3DO FZ-1 reboots after 5-10 minutes

Post by Tigri » Mon Jun 16, 2014 12:07 pm

I bought a Panasonic 3DO FZ-1 in a retro shop a few months ago. They demonstrated the system and it worked fine.

Then I tried to play a game at home and noticed that not all games loaded well. I opened up the case, cleaned the cd-rom lens and tried again. Now all my games worked.

The next problem I encountered was that I got a black screen after 20 minutes or so. I noticed that the left side of the 3DO got pretty hot. On the internet I read about replacing three capacitors on the left side of the drive. I replaced them with new low-esr capacitors and tried again. Now I could play 40-45 minutes before I got a black screen. Again, the left side got hot.

So I thought maybe if I could get rid of the heat, this would solve the problem. I opened the casing and aimed a fan at the 3DO. This worked wonders. I played for 2 hours. Then the audio started to fade and a few seconds later the system rebooted with the 3DO logo. After 5 seconds it booted again, and again and again.

I let the system cool off for a day and tried the same method again, this time increasing the fan cooling. And I could play the system for 2,5 hours. After which the system rebooted and again booted every 5 seconds.

I thought third time is the charm and did the exact same thing. However, now the system boots any game fine, but reboots after 5 minutes. Only way to boot a game again is to wait an hour and then it will only work for about 5 minutes. My crude solution doesn't work anymore. I don't feel any heat coming off the system anymore either. Also, the system works fine for those 5 minutes, so I suppose no critical chips have been damaged.

I'm out of ideas what I could try next to get the system to work again. Can anyone help me?

Post Reply