Yet another FZ-1 drive problem...

Got a problem with your 3DO? Ask!
Post Reply
Posts: 6
Joined: Mon Aug 18, 2014 12:16 pm

Yet another FZ-1 drive problem...

Post by Spirantho » Sat Aug 23, 2014 9:45 am

Hi everybody,

Apologies for this being my first post. I wanted my first post to be a "Hurrah! I fixed it!" post, but it's not quite.

The story so far....

My until-now-trusty FZ-1 was playing Road Rash after a longish hiatus (about 2 years since last play) and it suddenly went quiet. This immediately made me think of Amiga 1200s and their capacitors....
... so it wasn't terribly surprised when it stopped working completely. The machine would turn on (red light) and there'd be a whistling noise, and it would reset. It would keep doing this.
I recapped the entire beast, but it kept doing it.
Then I took some cleaning alcohol to the area around the power caps, and cleaned it all up - it came back! It lives!

However.. and this is the problem... it would load some games (e.g. Powers Kingdom), but not others (e.g. Syndicate, where it would repeatedly play the intro movie). Some games like Road Rash would play but would reset half way through a level at a particular point.
I cleaned the disk using a proper CD Cleaner from Maplin.
Then it didn't read the disk at all. But it still read other disks. Ish.

So... I cleaned the laser head. Still no change. Exactly the same.

By this point I was thinking the laser needed tweaking, as it presumably couldn't read the disc.

So, I opened the machine - again - and tweaked the potentiometer for the laser strength. I turned it about 1/8 turn anti-clockwise.
Now it was even worse.
So I tried it 1/4 turn clockwise (making it 1/8 off original).

Since then the motor has refused to turn at all. I think the laser can't focus - if I run it with no disk in, I can see the laser moving to try and get focus.
I've checked the worm gears and everything, they're fine. It just can't get a focus. I know the laser is working because I can see it (with a little help from my phone, as phone cameras can pick up IR light). It just can't focus.

Does anyone have a suggestion as to what I can do? I've tried re-tweaking the laser pot but the CD motor is not turning so presumably it's still trying to find a focus and can't. The current resistance measured between the 5th and 6th pins of the ribbon cable (the pins connected to the two sides of the potentiometer, in other words) is about 450 Ohms, but I've tried others.

Any suggestions would be greatfully received! Can a non-spinning motor be a symptom of a mis-tweaked pot?

Thanks !
Ian Gledhill
Mutant Caterpillar Games Ltd. - 8-bit and 16-bit games, machines and spare parts

Post Reply